
Unit-2 

Word Processor 

A word processor is software that allows users to create, edit, and print documents. It enables 

you to write text, store it electronically, display it on a screen, modify it by entering commands 

and characters from the keyboard, and print it.  

Standard Features of Word Processors : Word processors  support the following basic 

features- 

Insert text: Allows you to insert text anywhere in the document. 

Delete text: Allows you to erase characters, words, lines, or pages. 

Cut and Paste: Allows you to remove (cut) a section of text from one place in a document and 

insert (paste) it somewhere else. 

Copy: Allows you to duplicate a section of text. 

Page size and Margins: Allows you to define various page sizes and margins, and the word 

processor will automatically readjust the text so that it fits. 

Search and Replace: Allows you to direct the word processor to search for a particular word or 

phrase. You can also direct the word processor to replace one group of characters with another 

everywhere that the first group appears. 

Word wrap: Automatically moves to the next line when you have filled one line with text, and it 

will readjust text if you change the margins. 

Print: Allows you to send a document to a printer to get hard copy. 

Font specifications: Allows you to change fonts within a document. For example, you can 

specify bold, italics, and underlining.  

Spell checking: Identifies words that don't appear in a standard dictionary. 

Grammar checking: Identifies sentences, paragraphs, and punctuation that doesn't appear to 

meet commonly recognized rules of grammar. 

Automated lists: Automatically creates bulleted or numbered lists, including multi-level 

outlines. 
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Graphics: Allows you to embed illustrations, graphs, and possibly even videos into a document. 

Some word processors let you create the illustrations within the word processor; others let you 

insert an illustration produced by a different program. 

Headers, Footers, and Page numbering: Allows you to specify customized headers and footers 

that the word processor will put at the top and bottom of every page. The word processor 

automatically keeps track of page numbers so that the correct number appears on each page. 

Layout: Allows you to specify different margins within a single document and to specify various 

methods for indenting paragraphs. 

Merge: Allows you to merge text from one file into another file. This is particularly useful for 

generating many files that have the same format but different data. Generating mailing labels is 

the classic example of using merges. 

Thesaurus: Allows you to search for synonyms without leaving the word processor. 

 

Microsoft Word 

MS Word is used to create and edit personal and business documents, such as letters, reports, 

invoices, emails.  

 Microsoft Word can be used for the following purposes:  

 To create business documents having various graphics including pictures, 

charts, and diagrams.  

 To store and reuse readymade content and formatted elements such as cover 

pages.  

 To create letters and letterheads for personal and business purpose.  

 To design different documents such as resumes or invitation cards etc.  

 To create a range of correspondence from a simple office memo to legal copies 

and reference documents.  

  

Creating documents in MS-Word: To create a new file,do this- 

 Click  the Microsoft Office Button,located in the upper-left corner of the Word 

Ribbon. 

 Select New option , a dialog box will appear . 

 Select the type of document you wish to create(Blank document).  

 Click Create button. 

A blank document will appear on-screen ready for you to start entering 

information. 
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Saving documents in MS-Word: 

Once you are done with typing in your new Word document, it is time to save your document to 

avoid losing work you have done on a Word document.  

Following are the steps to save an edited Word document:  

 

 Click  the Microsoft Office Button, located in the upper-left corner of the Word Ribbon 

  Select Save As option. a dialog box will appear. 

 Select a folder where you will like to save the document, Enter the file name which you 

want to give to your document. 

 Finally, click on the Save button and your document will be saved with the entered name 

in the selected folder. 

 

 

Tables in MS-Word 

Tables  contains rows and columns.It is a grid of cells arranged in rows and columns. 

Tables are useful for various tasks such as presenting text information and numerical data. 

Creating Table:   To create a table,do this- 

 Place your insertion point where you want to table to appear,select the Insert tab. 

 Click the Table command. 

 A drop-down menu containing a grid of squares will appear.The mouse over the grid to 

select the number of columns and rows in the table. 

 Click the mouse and table will appear in the document. 

 You can now place the insertion point anywhere in the table to add text. 
 

Modifying Table: 

When you select a table in word ,the Layout tab appears under Table tools on the ribbon.You can 

modify your tables by using the options given in this tab.Moreover,you can change style,color of 

your table by using Design tab under Table Tools. 

Mail- Merge in MS-Word 

Suppose,you want to give a party to your friends and relatives.you have typed the invitation 

letter.Now,you have to type all the addresses of your friends and relatives.Typing all the names 

and addresses  and then making the documents and saving them,is a tedious job.This work can be 

done very easily in MS-WORD using the Mail Merge. 

With the help of Mail Merge.,you can send the same letter to a number of people. 

The Mail-Merge process requires the following: 

 

Main Document:The document that contains letter or text which is to be sent is called the Main 

Document. 



Data Source:The file where all the addresses of the recipients are stored is called the Data 

Source. 

The process of combining the Main Document with the Data Source is called Merging.The final 

document is called the Merged Document. 

In general,the Mail Merge process involves the following 3 steps: 

 

 Creating Main Document 

 Creating Data Source 

 Merging Main Document and Data Source 
 

To Mail Merge,following the given steps: 

 

 Click Mailings tab on the ribbon 

 Click Start Mail Merge option from the Start Mail Merge group and choose Letters 

from the choices available. 
 Type the letter you want to send. 

 Click Select Recipients option and choose Type New List from the choices available.

 The New Address List  dialog box appears. 

  Fill in the various fields with appropriate information. 

 To create another entry,click the New Entry button.     

 You can arrange the records according to your choice by clicking the appropriate 

column heading. For example,click First Name field to arrange according to names. 

 After completing the form,click OK button.      

 The Save Address List dialog box appears. 

 Give a suitable name to the list and click Save button. 

 Now,place the cursor in the main document where you want the fields to be inserted. 

 Click Insert Merge Field option from Write & Insert Fields group and choose the 

required field.Again,place the cursor to another place for the next field and insert it in the 

same manner. 

 Click Finish & Merge option from Finish group to complete the mail merge process. 

 Choose Edit Individual Documents option.The Merge to New Document dialog box 

appears. 

 Choose All option and click OK. 

 

The merged letters will be opened in MS Word window for further editing. 

            

        

Formatting in MS-Word 

To make a text in a document attractive,we have to change and arrange the text,which ia known 

as formatting a document.We can format our document using Font group and Paragraph group in 

the Home tab in MS-Word. 

Word divides formatting in to two types- 

 Character format:This format can be applied to individual characters with in a document. 



 Paragraph format:This format can be applied to whole paragraph with in a document. 

 

Making Text Bold,Italic and Underline: 

 
The following steps should be used to make text Bold. 

 Select the text you want to make bold. 

 On the Home tab,in the Font group,click Bold icon or press CTRL+B keys in the 

keyboard. 

The text becomes bold. 

 

The following steps should be used to make text Italic. 

 Select the text you want to make italic 

 On the Home tab,in the Font group,click Italic icon or press CTRL+I keys in the 

keyboard. 

The text becomes italic. 

 

The following steps should be used to make text Underline. 

 Select the text you want to make underline 

 On the Home tab,in the Font group,click Italic icon or press CTRL+U keys in the 

keyboard. 

The text becomes underline. 

 

 Add a decorative underline: 
 Select the text you want to make underline 

 On the Home tab,in the Font group,click the Font Dialog Box Launcher,and then click 

the Font tab. 

 In the Underline style box,click the style that you want. 

 To change the color of the underline,click Underline color,and then click the color that 

you want. 

 

 

Changing Font Style: 
 Font style is a option through which you can change the look and face of font. 

The following steps should be used to change the font of the text. 

 Select the text to change the font 

 On the Home tab, in the Font group, click the Font  drop-down list arrow option. 
 Choose the font type from the list and click it to apply. 

  

Changing Font Size: 
 Font size refers to the size of a character or word. 

The following steps should be used to change the font size. 

 Select the text to change the font size. 

 On the Home tab, in the Font group, click the Font size  drop-down list arrow option. 



 Choose the font size from the list and click it to apply. 
 

Changing Font Color: 
You can apply different colors to the text. 

To color the text,follow the given steps. 

 Select the text to change the font color. 

 On the Home tab, in the Font group, click the Font color  drop-down list arrow option. 
       A color palette appears. 

 Choose the color you want from the palette and click it to apply. 

 

Paragraph formats: 
 

When you need to control how a paragraph  lines up on a page,you apply paragraph 

formats. 

Alignment-Alignment refers to the way in which text is placed in a page. 

                       Word allows 4 ways of Alignment a paragraph. 

 Left Alignment 

 Right Alignment  

 Center Alignment  

 Justified 

To set Alignment a paragraph,follow the given steps- 

 Select the paragraph that you want to set  the alignment. 

 On the Home tab, in the Paragraph group, click the Alignment button 

The selected paragraph is aligned as desired. 

 

Indent-   Indent allow you to control the blank space at the left and right side of a   

     paragraph. 

Increase or decrease the left indent of an entire paragraph- 

 Select the paragraph that you want to change.  

 On the Page Layout tab, in the Paragraph group, click the  Indent Left 

arrows next button  to increase or decrease the left indentation of the 

paragraph.  
 

Increase or decrease the right indent of an entire paragraph- 

 Select the paragraph that you want to change.  

 On the Page Layout tab, in the Paragraph group, click the  Indent right 

arrows next button  to increase or decrease the right indentation of the 

paragraph.  
 

Indent only the first line of a paragraph- 

 
 Click in front of the line that you want to indent.  

 On the Page Layout tab, click the Paragraph Dialog Box Launcher, 

and then click the Indents and Spacing tab. 



 In the Special list under Indentation, click First line, and then in the By 

box, set the amount of space that you want the first line to be indented.  

 

Line spacing- Line spacing refers to the amount of vertical space between the lines of   

  text in a paragraph 

   To set Line spacing ,follow the given steps- 

 Select the paragraph that you want to set  the line spacing 

 On the Home tab, in the Paragraph group, click the Line spacing  option 

and chose the required number of spacing from the list to adjuct the space 

between lines. 

 

 

Paragraph spacing- Paragraph  spacing refers to the amount of space above or below a 

   paragraph 

   To set paragraph spacing ,follow the given steps- 

 Click anywhere in the paragraph to set the spacing before or after it 

 On the Home tab, in the Paragraph group, click the Paragraph 

Dialog Box Launcher. 

 Click   the Spacing Before or Spacing After arrows next button to 

increase or decrease the amount of space you want.. 

 

Unit-2 

MS-Excel 

 

Microsoft Excel is an electronic spreadsheet that runs on a personal computer. You can use it to 

organize your data into rows and columns.You can also use it to perform mathematical 

calculations quickly it . 

 

Workbook and Worksheet: 

Workbook-In Microsoft Excel,a workbook is the file in which you work and store your 

data.Each workbook contains many worksheet.It makes you organize various kinds of related 

information in a single file. 



Worksheet- Microsoft Excel consists of worksheets.Worksheet also known as Spreadsheet,is the 

primary document that we use in Excel to store and work with data.A worksheet consists of cells 

that are organized into columns and rows.Worksheet is always stored in a workbook.Each 

worksheet contains columns and rows.The columns are lettered A to Z and then continuing with 

AA,AB and so on;the rows are numbered 1,2,3 and so on. 

 

Creating and Saving a New workbook: 

 

To Create a new ,blank workbook- 
 

 Click Microsoft Office Button , and then click New.  Or Keyboard shortcut You can also 

press CTRL+N. 

 Under Templates, make sure that Blank and recent is selected, and then under Blank and 

recent in the right pane, click Blank Workbook. 

 

To Save a workbook- 
 

 Click  the Microsoft Office Button, located in the upper-left corner of the Excel Ribbon 

  Select Save As option. a dialog box will appear. 

 Select a folder where you will like to save the workbook, Enter the file name which you 

want to give to your document. 

 Finally, click on the Save button and your workbook will be saved with the entered name 

in the selected folder. 

 

Entering Information in a Worksheet: 

 

  Enter Data 

 

 Click the desired cell. 

 Type the data into the cell. 

 Press the Enter key to move down a cell. 

 Press the Tab key to move to the next cell to the right 

 

  Enter Dates 

 

 Click the desired cell.  

 Type a date  as follows: use a slash mark or a hyphen to separate the parts 

of a date; for example, type 9/5/2002 or 5-May-2020 

 Press the Enter key to move down a cell. 

 Press the Tab key to move to the next cell to the right 

 

Enter  Formula 



 

 Click the desired cell. 

 To indicate a formula will be in this cell, 

 type (=) followed by the formula.Example: =A1+3 

 Press Enter when finished typing the formula. 

 

 

Insert Columns in a worksheet: 

 

 Do one of the following:  

o To insert a single column, select the column or a cell in the column immediately 

to the right of where you want to insert the new column. For example, to insert a 

new column to the left of column B, click a cell in column B.  

o To insert multiple columns, select the columns immediately to the right of where 

you want to insert columns. Select the same number of columns as you want to 

insert. For example, to insert three new columns, you need to select three 

columns.  

 On the Home tab, in the Cells group, click the arrow next to Insert, and then click Insert 

Sheet Columns. 

 

Insert Rows in a worksheet: 

 

 Do one of the following:  

o To insert a single row, select the row or a cell in the row above which you want to 

insert the new row. For example, to insert a new row above row 5, click a cell in row 

5.  

o To insert multiple rows, select the rows above which you want to insert rows. Select 

the same number of rows as you want to insert. For example, to insert three new 

rows, you need to select three rows.  

 On the Home tab, in the Cells group, click the arrow next to Insert, and then click Insert 

Sheet Rows. 

  

Move or Copy rows and columns in a worksheet: 

When you move or copy rows and columns, Microsoft Office Excel moves or copies all of the 

the data that they contain, including formulas and their resulting values, cell formats and You 

can use the Cut command or Copy command to move or copy selected rows and columns, but 

you can also move or copy them by using the mouse. 
 



 Select the row or column that you want to move or copy.  
 Do one of the following: 

o To move rows or columns , on the Home tab, in the Clipboard group, c lick Cut 
button 

o  To copy rows or columns, on the Home tab, in the Clipboard group, click Copy button .  

 Right-click a row or column below or to the right of where you want to move or copy your selection, 
and then do one of the following:  

o When you are moving rows or columns, click Insert Cut Cells on the shortcut menu. 
o When you are copying rows or columns, click Insert Copied Cells on the shortcut menu. 

 

Preview worksheet pages before printing 

 

 Click the worksheet that you want to preview before you print it.  

 Click the Microsoft Office Button , click the arrow next to Print, and then click Print 

Preview.  

 On the Print Preview tab, do one or more of the following:  

o To preview the next and previous page, in the Preview group, click Next Page and 

Previous Page.  

o To view page margins, in the Preview group, select the Show Margins check box.  

 

This displays the margins in the Print Preview view. To make changes to the margins, you can 

drag the margins to the height and width that you want. You can also change the column widths 

by dragging handles at top of print preview page. 

 

To make page setup changes, on the Print Preview tab, in the Print group, click Page Setup, and 

then select the options that you want on the Page, Margins, Header/Footer, or Sheet tab of the 

Page Setup dialog box. 
 

Print a worksheet or workbook 

 

You can print entire or partial worksheets and workbooks, one at a time, or several at once. And 

if the data that you want to print is in a Microsoft Office Excel table, you can print just the Excel 

table. 

Print a partial or entire worksheet or workbook 

 Do one of the following:  

o To print a partial worksheet, click the worksheet, and then select the range of data 

that you want to print.  

o To print the entire worksheet, click the worksheet to activate it.  

o To print a workbook, click any of its worksheets. 

 Click Microsoft Office Button , and then click Print.  



 Under Print what, select an option to print the selection, the active sheet or sheets, or the 

entire workbook.  

 

To print quickly or to preview the printout before you print, click Microsoft Office Button , 

click the arrow next to Print, and then click Quick Print or Print Preview. 
 

Add or Change Page Headers and Footers 
 

In Microsoft Office Excel, you can quickly add or change headers or footers to provide useful 

information in your worksheet printouts. You can add predefined header and footer information 

or insert elements such as page numbers, the date and time, and the file name. 

For worksheets, you can work with headers and footers in Page Layout view.  

 

To create header and footer,do this- 

 

 Click the worksheet to which you want to add headers or footers, or that contains headers 

or footers that you want to change.  

 On the Insert tab, in the Text group, click Header & Footer. 

 Do one of the following:  

o To add a header or footer, click the left, center, or right header or footer text box 

at the top or at the bottom of the worksheet page.  

o To change a header or footer, click the header or footer text box at the top or at 

the bottom of the worksheet page that contains header or footer text, and then 

select the text that you want to change. 

 Type the text that you want. 

 

 To start a new line in a header or footer text box, press ENTER.  

 To delete a portion of a header or footer, select the portion that you want to delete 

in the header or footer text box, and then press DELETE or BACKSPACE. 

 To close the headers or footers, click anywhere in the worksheet, or press ESC.  

 

Charts in MS-Excel 

 

A pictorial representation of numeric data is called a chart or graph.It is more attractive and 

appealing than a simple presentation of data. 

 

Creating Chart: 

 
Creating a chart in Microsoft Office Excel is quick and easy. Excel provides a variety of chart 

types that you can choose from when you create a chart .It helps you display data in ways that 



are meaningful to your audience. When you want to create a chart or change an existing chart, 

you can choose from a wide range of chart subtypes available for each of the following chart 

types. 

To create a chart,do this- 

 

 On the worksheet, arrange the data that you want to plot in a chart.  

 Select the cells that contain the data that you want to use for the chart.  
 On the Insert tab, in the Charts group, do one of the following:  

 Click the chart type, and then click a chart subtype that you want to use.  
 To see all available chart types, click a chart type, and then click All Chart Types to 

display the Insert Chart dialog box, click the arrows to scroll through all available chart 
types and chart subtypes, and then click the the ones that you want to use. 

 

When you create a chart, the chart tools become available and the Design, Layout, and Format 

tabs are displayed. You can use the commands on these tabs to modify the chart so that it 

presents the data the way that you want. For example, 

 Use the Design tab to display the data series by row or by column, make changes to the 

source data of the chart, change the location of the chart, change the chart type, save a 

chart as a template, or select predefined layout and formatting options.  

 Use the Layout tab to change the display of chart elements such as chart titles and data 

labels, use drawing tools, or add text boxes and pictures to the chart.  

 Use the Format tab to add fill colors, change line styles, or apply special effects. 

 

 

 

 

 

 

 

 

 

 


